Back to overview
Downtime
Services are unavailable
Apr 16 at 11:03pm HDT
Affected services
natsuki.live hosting
Resolved
Apr 16 at 11:23pm HDT
We have resolved this incident.
Affected services
natsuki.live hosting
Created
Apr 16 at 11:03pm HDT
natsuki.live will be performing routine maintenance on April 17th starting at 10:10 (UTC+2). You may not be able to access any services for a short period of time, but we’ll have things back up and running as soon as possible to minimize disruption to you.
Affected services
natsuki.live hosting